Topic: Transferring out to foreign number

I'm having trouble transferring out to a foreign number. I have created a variable that is the phone number and have passed it into the transfer node. The number I am trying to transfer to is Czech. This is the format I have it in: 0420xxxxxxxxx.

0 to dial internaional
420 is the country code
and then the 9 digit phone number.

I am testing from the US (and from a US number), but I need this to be accessible from outside the US as well. I have also tried putting in 011 instead of 0 as this post suggests:

Regardless of what I do, the call gets dropped when it gets to the transfer node. I have tried calling the number in question from my personal phone, and I can get through fine.

Re: Transferring out to foreign number

We noticed you have a Czech number in your account. If you are trying to transfer to the Fuse app hosted at your Czech number, please use the Run Another App module, found under Data Integration.

If this is another Czech number, could you PM the specific number to us so we can determine the correct format?

Re: Transferring out to foreign number

The Czech number in my account is the number for the program to call into the IVR. The number I am trying to transfer out to is the live support number for said program. The number is +420 228880210. What is the correct format for it in the transfer node?

Re: Transferring out to foreign number

The format needs to be 011420228880210

To break it down:
011 - US country code to dial out
420 - Czech Republic country code to dial in
228880210 - The 9 digit Czech phone number

Re: Transferring out to foreign number

It's still not working. I realized I posted the wrong number. That's the number for the IVR itself. The number that it should transfer out to is:
+420 840 990 999. I have this in the node as 011420840990999. Using the "Run!" feature I watched it trace through the flow. It starts to transfer out, rings once, and then the transfer node flashes red and hangs up. When I dial the +420 840 990 999 number directly, I can get connected just fine. Please advise.

Re: Transferring out to foreign number

When we tried dialing that number from the US from a normal landline phone, we hear the message: "We're sorry, your call cannot be completed as dialed." Please make sure this number is properly configured with your carrier.

Re: Transferring out to foreign number

At the time of the post the CZ number may not have been active.  We have recently dialed the number several times from a cell phone in the US and have confirmed it is working.  We have attempted to transfer using 011420840990999 set as a variable in our IVR flow, but we fail to connect.

Just to confirm, we have dialed +420840990999 directly from a US based cell phone and successfully connected. 

As a side note, all of calls will originate in CZ.  We are concerned that if we get this working from the US we still may not have addressed the issue for the CZ customers.

Re: Transferring out to foreign number

Please enable custom timeouts in your transfer module. Allow your transfer to ring for 30 seconds or more. It's a good idea to also set a max length, too. Once you increase the timeout, your transfers should be able to connect.

Another issue we've run into is this: when we call that Czech number directly, we hear a woman speaking a foreign language (presumably Czech). However, if you call into your Fuse app and let it transfer, we've heard both a male and female voice speaking American English. And finally, if you use the Run! button, the transfer still connects, but there is either a clicking noise, or the sound of a dial up modem. Please let us know if this behavior is unexpected and we will look into it.

Re: Transferring out to foreign number

Hi. This is not expected behavior, and after setting custom timeouts I am now experiencing it as well. I suspect that I am being transferred somewhere else. One of the times I called I was told I had reached a "prayer line". I feel like we're getting closer since the call is no longer being dropped, but could you please look into where/ how the call is being routed? It is important to get this sorted out this week. Here is some information on our testing that might help you troubleshoot:

- The program itself is Czech, and 99% of users will be calling in from the Czech Republic using Czech numbers.
- I myself am currently in the US and am testing by calling in from a US number. The number that I am trying to transfer to is currently set to 011420840990999.
- I do have someone in the Czech republic that can test by calling in from a Czech number

1. Where am I being routed/ what do I need to do to connect to the correct number?
2. Will the prefix of the number need to change once the program is ready to go live to accommodate Czech callers?

Thank you